Summary
You may receive the following error when Snapshot attempts to connect to a repository when the Laserfiche client and Server have been configured to use the Laserfiche Firewall Compatibility Component:
IP Connection failed.
Cause
Snapshot 7.0 and 7.0.1 utilize an older client interface (LFAPI) when communicating with the Laserfiche Server. This means that it still uses the legacy LFAPI port when connecting to the Laserfiche Server. When setting up the client to use the Laserfiche Firewall Compatibility Component, if you attached a repository through the client without specifying the legacy LFAPI port, Snapshot will be unable to connect to that repository.
Resolution
This issue is resolved in Laserfiche Snapshot 7.0.2 and later. Please upgrade to the latest version of Laserfiche Snapshot.
Workaround
If you are using Laserfiche Snapshot 7.0 or 7.0.1, you can configure Snapshot to connect to the Laserfiche Server using the port specified during Firewall Compatibility Component configuration. This configuration must be performed for each Windows user who will be using Snapshot.
To configure Snapshot for use with the Laserfiche Firewall Compatibility Component
Note: You may have configured the Laserfiche Server to use a port other than 2040. If this is the case, you should use the port number you configured the Laserfiche Server to
use. Please see the following article for more information on configuring the Laserfiche Server with the Firewall Compatibility Component:
1000765 Configuring Laserfiche to be Firewall Compatible.
1011020 Disabling the Laserfiche Client's Automatic Reception of Repository Information.
ServerName:1888::ServerPort
where ServerName is the name of your Laserfiche Server and ServerPort is the port that the Laserfiche Server has been configured to use with the Firewall Compatibility Component.Note: This port number is usually 2040, but may vary depending on your Firewall Compatibility Component configuration.
More Information
The repository name, server, and port specified during the Attach process are stored in the registry at: HKEY_CURRENT_USER\SOFTWARE\Laserfiche\Client\Profile\IPDatabase.
To manually specify the port number for an attached Laserfiche repository
regedt32
ServerName:1888::ServerPort
where ServerName is the name of your Laserfiche Server and ServerPort is the port that the Laserfiche Server has been configured to use with the Firewall Compatibility Component.Note: This port number is usually 2040, but may vary depending on your Firewall Compatibility Component configuration.