An "IP Connection failed" Error Occurs When Using Snapshot with the Laserfiche Firewall Compatibility Component

November 14, 2005 | KB: 1011059
Snapshot 7

Summary

You may receive the following error when Snapshot attempts to connect to a repository when the Laserfiche client and Server have been configured to use the Laserfiche Firewall Compatibility Component:

    IP Connection failed.

Cause

Snapshot 7.0 and 7.0.1 utilize an older client interface (LFAPI) when communicating with the Laserfiche Server. This means that it still uses the legacy LFAPI port when connecting to the Laserfiche Server. When setting up the client to use the Laserfiche Firewall Compatibility Component, if you attached a repository through the client without specifying the legacy LFAPI port, Snapshot will be unable to connect to that repository.

Resolution

This issue is resolved in Laserfiche Snapshot 7.0.2 and later. Please upgrade to the latest version of Laserfiche Snapshot.

Workaround

If you are using Laserfiche Snapshot 7.0 or 7.0.1, you can configure Snapshot to connect to the Laserfiche Server using the port specified during Firewall Compatibility Component configuration. This configuration must be performed for each Windows user who will be using Snapshot.

To configure Snapshot for use with the Laserfiche Firewall Compatibility Component

  1. Determine the port which the Laserfiche Server has been configured to use with the Firewall Compatibility Component. By default, it is port 2040.

    Note: You may have configured the Laserfiche Server to use a port other than 2040. If this is the case, you should use the port number you configured the Laserfiche Server to use. Please see the following article for more information on configuring the Laserfiche Server with the Firewall Compatibility Component:
    1000765 Configuring Laserfiche to be Firewall Compatible.

  2. Disable the Laserfiche client's automatic reception of repository information. For detailed instructions, see the following article:

    1011020 Disabling the Laserfiche Client's Automatic Reception of Repository Information.

  3. You will need to attach the repository and specify the port numbers that Snapshot will use to connect. This can be done regardless of whether the repository has already been attached. To attach a Laserfiche repository and specify a port number, perform the following:
    1. Open the Laserfiche client and click Attach.
    2. In the Laserfiche Server option, type the following:

      ServerName:1888::ServerPort

      where ServerName is the name of your Laserfiche Server and ServerPort is the port that the Laserfiche Server has been configured to use with the Firewall Compatibility Component.

      Note: This port number is usually 2040, but may vary depending on your Firewall Compatibility Component configuration.

    3. In the Repository name option, type the name of your Laserfiche repository.
    4. Click Attach.

More Information

The repository name, server, and port specified during the Attach process are stored in the registry at: HKEY_CURRENT_USER\SOFTWARE\Laserfiche\Client\Profile\IPDatabase.

To manually specify the port number for an attached Laserfiche repository

  1. Click Start and then click Run.
  2. Type the following and press ENTER:

    regedt32

  3. Expand My Computer.
  4. Expand HKEY_CURRENT_USER.
  5. Expand Software.
  6. Expand Laserfiche.
  7. Expand Client.
  8. Expand Profile.
  9. Select IPDatabase.
  10. If a string value whose name is the same as the name of your repository already exists, select it. Otherwise, create it by opening the Edit menu and selecting New and then String value. The new string value should have the same name as your repository.
  11. From the Edit menu, select Modify. This will open an Edit String dialog box.
  12. In the Value data option, modify the string to read as follows:

    ServerName:1888::ServerPort

    where ServerName is the name of your Laserfiche Server and ServerPort is the port that the Laserfiche Server has been configured to use with the Firewall Compatibility Component.

    Note: This port number is usually 2040, but may vary depending on your Firewall Compatibility Component configuration.

  13. Click OK.