Summary
When opening a folder with a large number of subfolders, Laserfiche Web Access may take a long time to load the folder list. If the number of folders is sufficiently large, Web Access may appear to be not responding.
Cause
The folder listing is displayed as a table within Internet Explorer. Since it takes a long time for Internet Explorer to render a table with many rows, this may cause a significant delay when displaying a large number of folders.
Resolution 1
This issue is resolved in Web Access 7.1. Please upgrade to the latest version of Laserfiche Web Access.
Resolution 2
A hotfix is available for Web Access 7.0.2. If you are experiencing this issue with a previous version of Web Access, you will need to upgrade to Web Access 7.0.2 before applying the hotfix. The hotfix is an updated version of the following files: GetEntryListing.asp, langenglish.inc, langjs.inc, obf.js, and settings.inc. The hotfix versions of all five files have a last modified date of 6/28/2005.
To update Laserfiche Web Access 7.0.2
Note: The exact location of the Web Access\ASPs directory may vary slightly depending on your specific installation.
More Information
Updated versions of Web Access will no longer display the entire folder list in the folder tree pane if the number of folders exceeds the maximum display number set in the settings.inc file. However, the entire folder list will still appear in the contents pane. By default, the maximum display number is set to 100 folders. Once the hotfix has been applied, you can change this number by changing the MAX_FOLDER_TREE_BRANCH value in settings.inc from 100 to some other number. Please note that larger values will increase the amount of time it requires to load the folder list.