Summary
After creating a new document and assigning a list field value during the document creation process, you may find that the previous item in the list field is assigned to the new document instead of the item you selected. If you selected the first item in the list field during the creation process, you may find that the new document will not have a template assigned to it.
Cause
You will encounter this issue if the list field is not configured to include a blank item. Under this type of configuration, the Laserfiche client will still display a blank value in the list field in the New Document and Import to Laserfiche dialog boxes. Although this value is not actually in the list field, the Laserfiche client still includes it when checking the total number of items in the list field. This results in an off-by-one error when you specify a list field value.
Note: A list field can be configured to include a blank item by using the Laserfiche Administration Console. When adding list field items for a template, select the Add blank to the list check box.
Resolution 1
This issue is resolved in Laserfiche client 7.1.2. Please upgrade to the latest version of Laserfiche.
Resolution 2
There is a hotfix available for Laserfiche 7.1.1. The fix is an updated version of lf.exe and LfFieldBrowser11.ocx. The fix is included in lf.exe (version 7.1.1.410 and later) and LfFieldBrowser11.ocx (version 1.1.0.4 and later).
To update Laserfiche Client 7.1.1
regsvr32 "C:\Program Files\Common Files\Laserfiche\Controls\LfFieldBrowser11.ocx"
More Information
For information on other issues which are addressed by the same hotfix, please see the following Laserfiche Knowledge Base articles:
1001056 The Selected List Field Item in the Search Pane Resets After You Perform a Search.
1011027 You Cannot Select a List Field Item in the Search Pane by Using the Keyboard to Type in the First Few Characters of the Item.