A "There was a problem reading this document (114)" Error Occurs When Generating or Viewing a Generated PDF.

August 6, 2014 | KB: 1011008
Laserfiche 7, WebLink 7, Web Access 7

Summary

Generating a PDF using the Laserfiche client, WebLink, or Web Access, or opening a PDF which has been generated using one of these programs, may generate the following error:

    There was a problem reading this document (114)

When this occurs, the newly created PDF may have blank or missing pages.

Cause

By default, the backslash character (\) is a word delimiter. Laserfiche allows an administrator to configure the set of word delimiters. This error occurs when the backslash character (\) is no longer a word delimiter. Under this type of configuration, the Laserfiche client, WebLink, and Web Access will encounter issues when generating a PDF from a page that contains a backslash.

Workaround

This issue can be resolved by changing indexing properties, so that the backslash character is considered a word delimiter. After which, you will need to re-OCR all affected documents.

To set the backslash character as a word delimiter

  1. Open the Laserfiche Administration Console.
  2. Expand the desired Laserfiche Server.
  3. Expand the Repositories item.
  4. Expand the desired repository.
  5. Select the Index item.
  6. From the Action menu, select Properties.
  7. Select the Word Delimiter tab.
  8. Click the backslash (\) character. The background of the backslash character should be gray. A gray background indicates that the character in question is a word delimiter.
  9. Click OK.
  10. From the Control Panel, open Administrative Tools.
  11. Open Services.
  12. Select the Laserfiche Server 7 service.
  13. From the Action menu, select Restart.
  14. For WebLink or Web Access:
    1. Select the World Wide Web Publishing service.
    2. From the Action menu, select Restart.

To re-OCR documents

  1. Open the Laserfiche Client.
  2. Select the affected documents.
  3. From the Action menu, select OCR/Extract Text/Index.
  4. Make sure that the OCR / Extract Text check box is checked.
  5. If you wish to index the document, make sure that the Index entire document check box is selected. Please note that indexing is not necessary to resolve this issue.
  6. Click OK.