An "Error while printing report YourReport.jpg: Can't handle file extension jpg" Error Occurs During the Packet Creation Process.

December 2, 2005 | KB: 1001103
Agenda Manager 7.1

Summary

When publishing an agenda packet that contains a JPEG supporting document, you may receive the following error message:

    Error while printing report YourReport.jpg: Can't handle file extension jpg

Cause

Agenda Manager does not correctly control the PDF conversion process for JPEG documents.

Resolution 1

This issue is resolved in Laserfiche Agenda Manager 7.2. Please upgrade to the latest version of Agenda Manager.

Resolution 2

There is a hotfix available for Laserfiche Agenda Manager 7.1. The fix is an updated version of AMServer.exe (version 7.1.0.75 or later).

To update Agenda Manager 7.1

  1. Stop the Agenda Manager Server.
    1. Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    2. Scroll down and select Laserfiche Agenda Manager Service.
    3. From the Action menu, click Stop.
  2. Click the following link to download a zip file containing AMServer.exe (version 7.1.0.75).
    Hotfix_SCR23936.zip
  3. Replace the existing AMServer.exe located in the Agenda Manager Server installation folder with the updated version. By default, Agenda Manager Server is installed at C:\Program Files\Laserfiche\Agenda Manager Server.
  4. Restart the Agenda Manager Server.
    1. Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    2. Scroll down and select Laserfiche Agenda Manager Service.
    3. From the Action menu, click Start.

Note: The hotfix resolves this issue for any newly submitted JPEG supporting documents. However, you will have to re-upload any existing image reports that were submitted prior to applying the hotfix.