An "Error: 6000 (null)" Error Occurs When Sending E-mails with Attachments from Outlook 2003.

June 23, 2006 | KB: 1001090
Laserfiche 7

Summary

When you use the Send to Laserfiche option from Outlook 2003 on an e-mail with an attachment, you may receive the following error message:

    Error: 6000(null)

Cause

The Send to Laserfiche option uses Outlook to first save the e-mail to the file system in preparation for the import to Laserfiche. Laserfiche than uses MAPI to save any changes to this saved copy before finishing the import process. When performing the first step, Outlook 2003 creates a .msg file. The MAPI method used by Laserfiche is currently unable to save changes to the .msg file created by Outlook 2003.

Workaround

Save the desired e-mail message to a location on your computer and then import the message into Laserfiche from Windows Explorer.

More Information

This issue is partially resolved in Laserfiche 7.1.2. In Laserfiche 7.1.2, no error will occur when you use the Send to Laserfiche option to directly import an e-mail with an attachment if you choose to leave the attachment in the in the e-mail message. If you attempt to remove the attachment, you may receive the following error message:

    Failed to remove attachments from e-mail file.

If you wish to remove the attachment, the stated workaround still applies.