The Print Spooler May Become Unresponsive If a Print Job Name is Longer Than 142 Characters.

July 6, 2006 | KB: 1001082
Snapshot 7

Summary

A Snapshot print job with a name over 142 characters in length can cause the Print Spooler to become unresponsive. The print job does not print.

Cause

This is an issue with the Black Ice printer driver utilized by Snapshot 7.

Workaround

Configure the Snapshot printer to allow directly printing to the printer instead of spooling the print job.

To enable the Print directly to the printer option

  1. Click Start, point to Control Panel, and click Printers and Faxes.
  2. Select the Snapshot printer.
  3. From the File menu, click Properties.
  4. Click the Advanced tab.
  5. Clear the Enable advanced printing features option.
  6. Click Apply to save the change.
  7. Reselect Enable advanced printing features option.
  8. Click Apply to save the change.
  9. Select the Print directly to the printer option.
  10. Click OK to save the change and close the Lf Snapshot 7 Properties dialog box.

More Information

If the print job becomes unresponsive, you will have to manually stop the print job and restart the Print Spooler service.

To remove the print job

  1. In the Windows System Tray, double-click the printer icon.
  2. Select the affected print job.
  3. From the Document menu, click Cancel.
  4. Click Yes when prompted to confirm the print job cancellation.

To restart the Print Spooler service

  1. Click Start, point to Control Panel, Administrative Tools, and then click Services.
  2. Scroll down and select Print Spooler.
  3. From the Action menu, click Restart.

Related Links

For a related issue, please see the following Laserfiche Knowledge Base article.

1011075 A "Printer settings could not be saved." Error Occurs When Configuring Snapshot to "Print Directly to the Printer."