An "Invalid Pointer" Error Occurs When Using Laserfiche Scanning to Send Documents.

August 15, 2005 | KB: 1001054
Laserfiche 7.1.1

Summary

When sending a document to Laserfiche from Laserfiche Scanning, you may receive the following error message:

    Invalid Pointer

Cause

When scanning into a logical volume, Laserfiche Scanning may incorrectly reset the HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile\YourRepositorySettings\ScanVolume registry value to the current physical volume instead of the logical volume.

Resolution 1

This issue is resolved in Laserfiche Scanning 7.1.2. Please upgrade to the latest version of Laserfiche.

Resolution 2

There is a hotfix available for Laserfiche Scanning 7.1.1. The fix is an updated version of LFScan.exe. This fix is included in version 7.1.1.368 of LFScan.exe with a last modified date of August 02, 2005. The hotfix ensures that Laserfiche Scanning no longer incorrectly sets the ScanVolume registry value. However, you must first manually clear out the incorrect registry value.

Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.

To update Laserfiche Scanning 7.1.1

  1. Load the Windows Registry Editor.
    1. Click Start and then click Run.
    2. In the Run dialog box, type the following and then click OK to load the Windows Registry Editor:

      regedt32

  2. Close Laserfiche Scanning.
  3. Delete the HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile\YourRepositorySettings\ScanVolume registry value.
  4. Click here to download a zip file containing the updated version of LFScan.exe.
  5. Replace the LFScan.exe located in your Laserfiche Scanning installation folder with the updated version. By default, Laserfiche Scanning is installed at C:\Program Files\Laserfiche\Laserfiche Scanning.