Opening a Folder From the Search Results Window Can Be Slow When a Parent Folder Contains Many Subfolders.

August 15, 2005 | KB: 1001051
Laserfiche 7

Summary

Laserfiche takes a long time when opening a folder from the search results window if the folder has a parent folder that contains a large number of subfolders.

Cause

When a folder is opened from the search results window, a new folder browser window is opened. When the new folder browser window is opened, the folders pane expands to the appropriate folder. If a parent folder contains a large number of subfolders, this operation may take a long time.

Resolution1

You can change the behavior of Laserfiche client 7.2 so that opening a folder from the search results window will use the selected folder as the "root folder" of the new folder browser window by editing the HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile\Settings\PopulateFolderTree registry string.

To edit the PopulateFolderTree registry string

  1. Click Start and then click Run
  2. Type the following and then click OK to load the Windows Registry Editor.

    regedt32

  3. Expand HKEY_CURRENT_USER.
  4. Expand Software.
  5. Expand Laserfiche.
  6. Expand Client.
  7. Expand Profile.
  8. Select Settings.
  9. From the Edit menu, point to New and select String Value.
  10. Name the string:

    PopulateFolderTree

  11. Double-click the newly-created string value to load the Edit String dialog box and set the value to 0.

Resolution 2

There is a hotfix available for Laserfiche client 7.1.x. The fix is an updated version of LF.exe. This fix is included in LF.exe (version 7.1.1.409). Opening a folder from the search results window now uses the selected folder as the "root folder" of the new folder browser window.

Note: Since the subfolder is used as the "root folder" of the folders pane, you will be prevented from performing certain actions on that subfolder when using that instance of the folder browser window. The affected actions are the ones that you cannot normally perform on the real root folder, such as deleting or renaming the folder.

Note: As this new behavior may not be desired for all users, please only download this hotfix if you are encountering this particular issue.

To update Laserfiche client

  1. Close the Laserfiche client.
  2. Click here to download a zip file containing LF.exe (version 7.1.1.409).
  3. Replace the LF.exe found in the Laserfiche client installation folder with the one included in the zip file.