Summary
Laserfiche may perform slower than expected when accessing large volumes.
Cause
There is a missing database index that affects the efficiency of volume size calculations. This can cause certain Laserfiche operations to run extremely slow on repositories with large volumes.
Resolution 1
This issue is resolved in Laserfiche Server 7.1.2. Please upgrade to the latest version of Laserfiche.
Resolution 2
There is a hotfix available for Laserfiche 7.1.x. The fix is a SQL script that creates the missing index.
Note: If the repository is upgraded to 7.1.2 at any point after applying the hotfix, the upgrade process will require additional configuration to successfully upgrade the repository. See "More Information" for details.
To update the SQL database
cmd
OSQL -S SQLInstance -E -d DatabaseName -i "PathToScript"
SQLInstance is the name assigned to the instance of SQL Server to which your SQL database is attached. By default, the instance name is the name of the computer hosting SQL Server.
DatabaseName is the name of the SQL database associated with your Laserfiche repository.
PathToScript is the location of add_index.sql.
More Information
If this hotfix is applied and subsequently the installation is upgraded to 7.1.2, you will need to do some additional configuration of the 7.1.2 upgrade process to allow it to successfully complete the upgrade. For more information on this process, see the following Knowledge Base article:
1011060 FIX: A "There is already an index on table 'Doc' named 'IX_Doc_TocId'." Error Occurs When Upgrading a Repository for Use with Laserfiche 7.1.2.