Laserfiche Server Can Time Out More Quickly Than Expected.

August 7, 2014 | KB: 1001048
Laserfiche 7.1

Summary

Stored procedure calls can time out more quickly than expected. The repository's error.log file contains entries involving timeouts and error code 7050.

Cause

Laserfiche was not correctly recognizing the Stored Procedure Timeout value specified in the DBOptions table and would use a default value instead of the specified value.

Resolution 1

This issue is resolved in Laserfiche Server 7.1.2. Please upgrade to the latest version of Laserfiche.

Resolution 2

There is a hotfix available for Laserfiche Server 7.1.1. The fix is an updated version of LFEng.dll. This fix is included in LFEng.dll (version 7.1.1.430 and later). Laserfiche Server now correctly uses the Stored Procedure Timeout value specified in the DBOptions table.

Note: This issue is present in both Laserfiche Server 7.1.0 and Laserfiche Server 7.1.1; however, the hotfix is only available for Laserfiche Server 7.1.1. If you are encountering this problem while using Laserfiche Server 7.1.0, please update your Laserfiche Server to 7.1.1 before applying this hotfix.

To update the Laserfiche Server 7.1.1

  1. Click here to download a zip file containing LFEng.dll (version 7.1.1.430).
  2. Replace the LFEng.dll located in the Laserfiche Server installation folder with the updated version. By default, Laserfiche Server is installed at C:\Program Files\Laserfiche\Server.
  3. Restart the Laserfiche Server service.
    1. Click Start, navigate to Control Panel, Administrative Tools, and select Services.
    2. Scroll down and select Laserfiche Server 7.x.
    3. From the Action menu, click Restart.

To update a Standalone edition of Laserfiche 7.1.1

  1. Click here to download a zip file containing LFEng.dll (version 7.1.1.430).
  2. Replace the LFEng.dll found in the installation folder. By default, a Standalone edition of the client is installed at C:\Program Files\Laserfiche\Client.