"Unknown error. [800]" is Reported When Browsing Through Folders.

August 6, 2014 | KB: 1001047
Laserfiche 7, WebLink 7

Summary

The following error is reported when browsing through Laserfiche folders:

    Unknown error. [800]

Cause

This error is generated when the following conditions are true:

  • The currently installed version of LfSO71.dll is either 7.1.0.280 or 7.1.0.281.
    Or:
    The currently installed version of LaserficheServerObjects.dll is 7.0.0.400.
  • Detailed information is being displayed in the contents pane of the folder browser.
  • One or more columns being displayed corresponds to a Date or Date/Time field.
  • One or more of those Date or Date/Time columns is associated with multiple fields.
  • The fields associated with that column have the same name, but whose capitalization is different. For example, this issue would occur if a field called "Date" has been selected to be displayed in the folder browser and another field called "date" has been created for another template.

Resolution 1

This issue is resolved in Laserfiche client 7.1.2. Please upgrade to the latest version of Laserfiche.

Resolution 2

There are hotfixes for Laserfiche Client 7.1.x and WebLink 7.0.x. The fix is an updated version of LFSO71.dll and LaserficheServerObjects.dll. This fix is included in LFSO71.dll (version 7.1.0.282 and later) and in LaserficheServerObjects.dll (version 7.0.0.401 and later).

To update Laserfiche 7.1.x

  1. Click here to download a zip file containing LFSO71.dll (version 7.1.0.282) and LaserficheServerObjects.dll (version 7.0.0.401).

    Note: The LaserficheServerObjects.dll file is not used by the Laserfiche Client and therefore you do not need to install it.

  2. Replace the LFSO71.dll located at C:\Program Files\Common Files\Laserfiche\LFObjects with the one included in the zip file.
  3. Register LFSO71.dll.
    1. Click Start and then click Run.
    2. In the Run dialog box, type the following and then click OK to register LFSO71.dll:

      regsvr32 "C:\Program Files\Common Files\Laserfiche\LFObjects\LFSO71.dll"

To update Laserfiche WebLink 7

  1. Click here to download a zip file containing LFSO71.dll (version 7.1.0.282) and LaserficheServerObjects.dll (version 7.0.0.401).

    Note: The LFSO71.dll file is not used by Laserfiche WebLink and therefore you do not need to install it.

  2. Replace the LaserficheServerObjects.dll located at C:\Program Files\Common Files\Laserfiche\LFObjects with the one included in the zip file.
  3. Register LaserficheServerObjects.dll.
    1. Click Start and then click Run.
    2. In the Run dialog box, type the following and then click OK to register LaserficheServerObjects.dll:

      regsvr32 "C:\Program Files\Common Files\Laserfiche\LFObjects\LaserficheServerObjects.dll"