Data Execution Prevention in Windows XP (Service Pack 2) and Windows Server 2003 (Service Pack 1) Can Prevent Scanning.

May 16, 2005 | KB: 1000970
Laserfiche 6, Laserfiche 7

Summary

When you attempt to scan pages in Laserfiche 7, you may receive the following error message:

    Data Execution Prevention - Microsoft Windows
    To help protect your computer, Windows has closed this program.
    Name: Program Name

    Data Execution Prevention helps protect against damage from viruses or other threats. Some programs may not run correctly when it is turned on. For an updated version of this program, contact the publisher.

When you close the error message, Laserfiche Scanning closes.

Version 6: When you attempt to scan pages in Laserfiche 6, no visible action occurs. However, the Event Viewer reports an error with the scan engine.

Cause

Data Execution Prevention (DEP) has been enabled for all programs and services. DEP prevents code from being run from certain memory locations.

Workaround 1

If your computer is set to apply DEP to all programs and services, add Laserfiche Scanning as an exception to your DEP configuration.

To configure DEP for Laserfiche 7

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and then click OK to load the System Properties dialog box:

    sysdm.cpl

  3. In the System Properties dialog box, click the Advanced tab.
  4. Under Performance, click Settings.
  5. In the Performance Options dialog box, click the Data Execution Prevention tab.
  6. Click Add.
  7. Browse to the LFScan.exe located in the Laserfiche Scanning installation folder. By default, Laserfiche Scanning is installed at C:\Program Files\Laserfiche\Laserfiche Scanning.
  8. Select LFScan.exe and click Open.
  9. Click OK to accept the changes.
  10. Restart your computer to complete the process.

To configure DEP for Laserfiche 6

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and then click OK to load the System Properties dialog box:

    sysdm.cpl

  3. In the System Properties dialog box, click the Advanced tab.
  4. Under Performance, click Settings.
  5. In the Performance Options dialog box, click the Data Execution Prevention tab.
  6. Click Add.
  7. Browse to the scan engine executable located in the Laserfiche Client installation folder. By default, Laserfiche Client is installed at C:\Program Files\Laserfiche\LFW. The possible scan engines are LFWISISN.exe, LFKOFAX.exe, LFTWAIN.exe, and LFUNVCPT.dll.
  8. Select the appropriate scan engine and click Open.
  9. Click OK to accept the changes.
  10. Restart your computer to complete the process.