Printing or Exporting Pages from Repositories Published using Plus 6.11 and Laserfiche Client 6.12 May Generate Blank Pages.

April 15, 2005 | KB: 1000944
Laserfiche 6.12, Plus 6.12

Summary

Printing or exporting pages from published repositories may result in blank pages being printed or exported.

Cause

Laserfiche 6.12 is dependent on updated image processing files that Plus 6.11 is unaware of when publishing. This issue does not occur if Laserfiche Client 6.12 is already installed on the computer viewing the published repository. Laserfiche Plus 6.12 resolves this issue. See Workaround 1 to configure Laserfiche Plus 6.11 to include the updated files when publishing a repository. If you do not wish to publish a previously published repository again, see Workaround 2 for steps on manually copying the necessary files onto a client computer.

Resolution

This issue is resolved in Laserfiche Plus 6.12. Please upgrade to the latest version of Plus.

Note: This fix only affects new CDs published using Plus 6.12.

Workaround 1

Modify the Plus 6.11 configuration file to configure Laserfiche Plus to include the new files when publishing.

To update the CDCommon.txt file

  1. From a text editor, open the CDCommon.txt file. This file is located in the Laserfiche Client installation folder. By default, the Laserfiche Client installation folder is C:\Program Files\Laserfiche\LFW.
  2. Add the following lines to the file:

    LFIMGSNW61.dll
    LFIMGSNW70.dll
    LFIMGSNW71.dll
    SNDB12CM.dll
    SNBD13cm.dll

  3. Save the changes and close the file.
  4. Republish the CD.

Workaround 2

If republishing is not an available option, manually copy the needed files onto the appropriate client computers.

To manually copy the needed files to the a client computer

  1. Browse to the following folder on a computer with Laserfiche Client 6.12 installed:

    C:\Program Files\Common Files\Laserfiche\System

  2. Copy the following files onto any computer that needs to export/print pages from a published repository. If C:\Program Files\Common Files\Laserfiche\System exists, the files should be placed there. If the folder does not exist, then the files should be placed into any folder defined in your Windows Path variable (e.g. C:\Windows). Alternatively, you could manually create the C:\Program Files\Common Files\Laserfiche\System folder, copy the files to the newly created folder, and add the folder to the Windows Path variable.

    LFIMGSNW61.dll
    LFIMGSNW70.dll
    LFIMGSNW71.dll
    SNDB12CM.dll
    SNBD13cm.dll

    Warning: Be aware that should you decide to manually copy these files to a location other than C:\Program Files\Common Files\Laserfiche\System, installing a Laserfiche client on that computer at a future date will result in duplicate copies of the aforementioned files. In such a case, remove the ones you manually created.