Summary
The Laserfiche Server is not broadcasting a registered repository. As a result, the Laserfiche client and the Laserfiche Administration Console cannot display that repository.
Cause
If the LFS.log file contains the messages listed in the More Information section, then the Laserfiche Server is unable to access the index files used for searching. See Workaround 1.
In addition, your Laserfiche repository may not display if the Laserfiche Server tries to connect to Microsoft SQL Server before Microsoft SQL Server has finished loading. See Workaround 2.
Workaround 1
Delete the .idx files found in the SEARCH subfolder of your repository folder and then restart the Laserfiche Server. The Laserfiche Server will regenerate a new set of files for use. Be sure to reindex your repository.
To restart the Laserfiche Server
Workaround 2
For more information on how to configure Laserfiche to wait for Microsoft SQL Server, please see the following Laserfiche Knowledge Base article:
1000713 Your Laserfiche Repository Does Not Display After You Restart the Computer.
More Information
If the following error messages are logged in the LFS.log file, then the index files for the specified repository may be corrupted.
[7000] Open repository 'RepositoryName' failed: sdbOpenFiles failed. Unable to create files needed in SEARCH directory.
[7000.0] Unable to open repository 'RepositoryName': sdbOpenFilesfailed. Unable to create files needed in SEARCH directory.