A "A volume already exists at the specified location. (7313)" Error Occurs When Changing a Volume's Removable Path.

March 11, 2005 | KB: 1000911
Server (MSDE) 7, Server (MSSQL) 7, Server (Oracle) 7

Summary

When you modify a volume's removable path, you may receive the following error message:

    A volume already exists at the specified location. (7313)

Cause

When the volume path is modified through the Laserfiche Administration Console, Laserfiche checks to see that a volume does not already exist at the specified location. If there is a volume, the server checks the volume name specified in the volume.id file against the name of the volume whose path you are changing. If the volume name specified in the volume.id file contains a space, Laserfiche does not correctly parse the name, resolves that there is a different volume located at the specified path, and returns the error specified in the above summary. See the provided resolution to resolve this issue.

Resolution

This issue is resolved in Laserfiche 7.0.3 and later. Please upgrade to the latest version of Laserfiche.

Workaround

If you are using Laserfiche 7.0.2 and you do not wish to upgrade to the latest version, then you may apply a hotfix to your installation. The fix is an updated version of LFENG.dll. This fix is included in LFENG.dll version 7.0.2.560 and later.

To update the Laserfiche Server

  1. Click here to download a zip file containing version 7.0.2.560 of LFENG.dll.
  2. Replace the LFENG.dll found in the Laserfiche Server installation folder with the LFENG.dll included in the zip file. By default, the Laserfiche Server is installed to C:\Program Files\Laserfiche\Server.
  3. Restart the Laserfiche Server.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Scroll down and select Laserfiche Server 7.x.
    5. From the Action menu, click Restart.

More Information

If there actually is a different volume at the specified path, please specify the correct path.