Exporting Briefcases and Publishing Data Fails Due to Lack of Disk Space.

August 7, 2014 | KB: 1000907
Laserfiche 7, Plus 7

Summary

If there is insufficient temporary disk space when exporting data from Laserfiche, then one of the following will occur.

  • Exporting a briefcase under these circumstances will generate an invalid briefcase.
  • Publishing a Laserfiche repository using an invalid briefcase can cause the publishing process to fail with error 7522. Additionally, you may receive the following error message:

      XML Parsing error 80004005 at line 0 column 0: Unspecified error

Cause

Laserfiche Server does not check for sufficient disk space when exporting a briefcase. Similarly, Laserfiche Plus does not check for sufficient disk space when extracting a briefcase.

Workaround

There are several possible workarounds to this issue:

  • Instead of publishing or exporting a single large job, split it up into smaller jobs.
  • Increase the amount of available disk space for the Windows temporary directory (as defined by the TMP environment variables on both the computer hosting the Laserfiche Server and the computer running Laserfiche Plus).
  • Modify the TMP environment variables on the computer hosting the Laserfiche Server to point to another local drive with more available disk space.
    1. Click Start and then click Control Panel.
    2. Double-click System.
    3. Click the Advanced tab.
    4. Click Environment Variables.
    5. Perform one of the following:
      • If the Laserfiche Server service logs in using a domain user account, under the User variables for Username section, select the TMP variable.
      • If the Laserfiche Server service logs in using the Local System account, under the System variables section, select the TMP variable.
    6. Click Edit. In the Variable value field, specify the desired path.
    7. Click OK to close the Environment Variables dialog box and to save your changes.
    8. Restart the computer.
  • Modify the TMP environment system variable on the computer running Laserfiche Plus to point to another local drive with more available disk space.
    1. Click Start and then click Control Panel.
    2. Double-click System.
    3. Click the Advanced tab.
    4. Click Environment Variables.
    5. Under the System variables section, select the TMP variable.
    6. Click Edit. In the Variable value field, specify the desired path.
    7. Click OK to close the Environment Variables dialog box and to save your changes.
    8. Restart the computer.

More Information

When exporting a briefcase, the Laserfiche Server writes the information being exported to a temporary location on the computer hosting the Laserfiche Server. This temporary location is specified by the TMP environment variable (User or System). It then packages and compresses this information into a briefcase file. As a result, this procedure requires more than twice the size of the resulting briefcase file on the computer hosting the Laserfiche Server.

If the local drive specified by the Windows temporary directory on the computer hosting the Laserfiche Server does not have sufficient space to handle the content being exported, then an incomplete and invalid briefcase file will be generated. However, an error message will not be reported.

This Laserfiche Server issue also affects publishing Laserfiche data using Laserfiche Plus, because Plus uses the briefcase exported by the Laserfiche Server during the publishing process. If this briefcase is incomplete, Plus may be unable to complete the publishing process or the final published repository may be missing documents. If the intermediate briefcase is missing the volume XML files, the publishing process will fail with an error 7522. If the intermediate briefcase is missing documents, the publishing process will complete, but the published repository will be missing those documents.

Plus will extract the contents of the briefcase exported by the Laserfiche Server during the publishing process. This data is temporarily written to the TMP path of the computer running Laserfiche Plus as well as the temporary directory specified in the Laserfiche Plus wizard. This procedure may require more than three times the size of the briefcase. This operation is a client-side operation different from the Laserfiche Server briefcase export step. Thus, to successfully publish a Laserfiche repository, make sure that there is enough disk space at both temporary locations: the TMP path on the Laserfiche Server and the TMP path on the Laserfiche Plus computer.