Summary
When you open a document, you may receive the following error message:
Failed to create empty document
Cause
This issue can occur if the Laserfiche text and image controls try to write incorrect registry information.
Resolution 1
Re-register the image and text controls. The specific files that you will need to register depend on the version of Laserfiche you are using. If you are using Laserfiche 7.0.x, you will need to register LFImage.ocx and LFText.ocx; if you are using Laserfiche 7.x, you will need to register LFImage7x.ocx and LFText7x.ocx.
To register LFImage.ocx and LFText.ocx
regsvr32 "C:\Program Files\Common Files\Laserfiche\Controls\LFText.ocx" "C:\Program Files\Common Files\Laserfiche\Controls\LFImage.ocx"
To register LFImage71.ocx and LFText71.ocx
regsvr32 "C:\Program Files\Common Files\Laserfiche\Controls\LFText71.ocx" "C:\Program Files\Common Files\Laserfiche\Controls\LFImage71.ocx"
To register LFImage72.ocx and LFText72.ocx
regsvr32 "C:\Program Files\Common Files\Laserfiche\Controls\LFText72.ocx" "C:\Program Files\Common Files\Laserfiche\Controls\LFImage72.ocx"
Resolution 2
Delete the DocLayout string value in the HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile\RepositoryNameSettings registry key. The next time the document viewer in the Laserfiche Client is started, this registry key will be created anew.
Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.
To remove the DocLayout string value
regedt32
Resolution 3
Delete the HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile\DocFrame registry key. The next time the Laserfiche Client is started, this registry key will be created anew.
Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.
To remove the HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile\DocFrame registry key
regedt32
Resolution 4
Delete the HKEY_CURRENT_USER\Software\Laserfiche\Client registry key. The next time the Laserfiche Client is started, this registry key will be created anew.
Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.
To remove the HKEY_CURRENT_USER\Software\Laserfiche\Client registry key
regedt32