A "Failed to create empty document." Error Occurs When Opening a Document.

February 25, 2005 | KB: 1000904
Laserfiche 7

Summary

When you open a document, you may receive the following error message:

    Failed to create empty document

Cause

This issue can occur if the Laserfiche text and image controls try to write incorrect registry information.

Resolution 1

Re-register the image and text controls. The specific files that you will need to register depend on the version of Laserfiche you are using. If you are using Laserfiche 7.0.x, you will need to register LFImage.ocx and LFText.ocx; if you are using Laserfiche 7.x, you will need to register LFImage7x.ocx and LFText7x.ocx.

To register LFImage.ocx and LFText.ocx

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and then click OK to register LFImage.ocx and LFText.ocx:

    regsvr32 "C:\Program Files\Common Files\Laserfiche\Controls\LFText.ocx" "C:\Program Files\Common Files\Laserfiche\Controls\LFImage.ocx"

To register LFImage71.ocx and LFText71.ocx

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and then click OK to register LFImage71.ocx and LFText71.ocx:

    regsvr32 "C:\Program Files\Common Files\Laserfiche\Controls\LFText71.ocx" "C:\Program Files\Common Files\Laserfiche\Controls\LFImage71.ocx"

To register LFImage72.ocx and LFText72.ocx

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and then click OK to register LFImage72.ocx and LFText72.ocx:

    regsvr32 "C:\Program Files\Common Files\Laserfiche\Controls\LFText72.ocx" "C:\Program Files\Common Files\Laserfiche\Controls\LFImage72.ocx"

Resolution 2

Delete the DocLayout string value in the HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile\RepositoryNameSettings registry key. The next time the document viewer in the Laserfiche Client is started, this registry key will be created anew.

Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.

To remove the DocLayout string value

  1. Close any open document viewer instances in the Laserfiche client.
  2. Click Start and then click Run.
  3. In the Run dialog box, type the following and then click OK to load the Windows Registry Editor tool:

    regedt32

  4. Expand HKEY_CURRENT_USER.
  5. Expand Software.
  6. Expand Laserfiche.
  7. Expand Client.
  8. Expand Profile.
  9. Expand RepositoryNameSettings, where RepositoryName is the name of your Laserfiche repository.
  10. Select the DocLayout value.
  11. From the Edit menu, click Delete.

Resolution 3

Delete the HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile\DocFrame registry key. The next time the Laserfiche Client is started, this registry key will be created anew.

Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.

To remove the HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile\DocFrame registry key

  1. Close any open Laserfiche client instances.
  2. Click Start and then click Run.
  3. In the Run dialog box, type the following and then click OK to load the Windows Registry Editor tool:

    regedt32

  4. Expand HKEY_CURRENT_USER.
  5. Expand Software.
  6. Expand Laserfiche.
  7. Expand Client.
  8. Expand Profile.
  9. Select DocFrame.
  10. From the Edit menu, click Delete.

Resolution 4

Delete the HKEY_CURRENT_USER\Software\Laserfiche\Client registry key. The next time the Laserfiche Client is started, this registry key will be created anew.

Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.

To remove the HKEY_CURRENT_USER\Software\Laserfiche\Client registry key

  1. Close any open Laserfiche client instances.
  2. Click Start and then click Run.
  3. In the Run dialog box, type the following and then click OK to load the Windows Registry Editor tool:

    regedt32

  4. Expand HKEY_CURRENT_USER.
  5. Expand Software.
  6. Expand Laserfiche.
  7. Select Client.
  8. From the Edit menu, click Delete.