Documents and/or Folders are no Longer Being Routed.

February 18, 2005 | KB: 1000892
Workflow Suite 7

Summary

Server Automation becomes stuck in the middle of processing an event. No error messages are returned and no successive documents will be routed.

Cause

Server Automation cannot process an event If the audit XML file generated by Laserfiche Server exceeds a certain size.

Resolution 1

This issue is resolved in Laserfiche Workflow Suite 7.0.1. Please upgrade to the latest version of Workflow Suite.

Resolution 2

There is a hotfix available for Laserfiche Workflow Suite 7.0 that will correctly process larger events. The fix is an updated version of AuditEvents.jar.

To update Workflow Suite

  1. Click here to download a zip file containing an updated version of AuditEvents.jar.
  2. Stop the Laserfiche Server Automation service.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Select Laserfiche Server Automation and from the Action menu, click Stop.
  3. Replace the AuditEvents.jar found in your Server Automation installation folder with the AuditEvents.jar included in the zip file. By default, it is located at C:\Program Files\Laserfiche\WorkflowSuite\ServerAutomation.
  4. Restart the Laserfiche Server Automation service.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Select Laserfiche Server Automation and from the Action menu, click Start.