Incorrect Image Highlights When Viewing Search Results.

February 14, 2005 | KB: 1000889
Laserfiche 7.0.2

Summary

When you perfom a text search, the correct word is highlighted in the search results and in the text. However, the corresponding highlight on the image does not correctly match up.

Cause

When indexing, the Laserfiche Server can break down large words into four-digit sets. This can conflict with how Laserfiche calculates word locations on the associated image. Additionally, adding or removing word delimiters could incorrectly affect location data.

Resolution

This issue is resolved in Laserfiche 7.0.3 and later. Please upgrade to the latest version of Laserfiche.

Note: You must reindex your repository for the fix to take effect.

Workaround

If you are using Laserfiche 7.0.2 and you do not wish to upgrade to the latest version, then you may apply a hotfix to your installation. The fix is an updated version of LFENG.dll and an updated version of LFIRISCOM.dll. This fix is included in LFENG.dll version 7.0.2.540 and later and in LFIRISCOM.dll version 6.1.0.11.

Note: You must reindex your repository for the fix to take effect.

To update the Laserfiche Server

  1. Click here to download a zip file containing version 7.0.2.540 of LFENG.dll.
  2. Replace the LFENG.dll found in the Laserfiche Server installation folder with the LFENG.dll included in the zip file. By default, the Laserfiche Server is installed to C:\Program Files\Laserfiche\Server.
  3. Restart the Laserfiche Server.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Scroll down and select Laserfiche Server 7.x.
    5. From the Action menu, click Restart.

To update the IRIS Laserfiche Interface

  1. Click here to download a zip file containing version 6.1.0.11 of LFIRISCOM.dll.
  2. Replace the LFIRISCOM.dll found in the C:\Program Files\Common Files\Laserfiche\Batch Processor\LFIris folder with the one found in the zip file.