A "183: Cannot create a new file when that file already exists." Error Occurs When Starting the Laserfiche Server.

February 14, 2005 | KB: 1000888
Server (MSDE) 7, Server (MSSQL) 7, Server (Oracle) 7

Summary

When starting the Laserfiche Server service, you may receive the following error message:

    183: Cannot create a new file when that file already exists.

Cause

This is a generic Windows Services error that is returned when a service cannot be successfully started. There are a variety of possible situations that can prevent the Laserfiche Server service from successfully starting. Here are several common causes:

  • The Laserfiche Server license is invalid. See Resolution 1.
  • The communication port that Laserfiche Server uses in unavailable. It may be in use by another program. See Resolution 2.
  • The path to the executable for the Laserfiche Server service may be invalid. See Resolution 3.
  • The path to the Laserfiche shared system files may be invalid. See Resolution 4.
  • The Laserfiche Server installation may be incomplete. See Resolution 5.
  • Laserfiche Server is installed on Windows Server 2003 and is using the Local System account. See Resolution 6.
  • A required file (LFLIC.ocx) has not been registered on the computer hosting the Laserfiche Server. See Resolution 7.

Resolution 1

Please contact your certified dealer to verify that you have a valid Laserfiche Server license.

Resolution 2

By default, Laserfiche Server uses port 1888 for communication with Laserfiche clients. If another program is also using this port, Laserfiche Server may be unable to start. Configure Laserfiche Server or the other program to use a different port.

Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.

To change the port used by the Laserfiche Server

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and then click OK to load the Windows Registry Editor utility.

    regedt32

  3. Expand HKEY_LOCAL_MACHINE.
  4. Expand SOFTWARE.
  5. Expand LASERFICHE.
  6. Expand Engine.
  7. Click 7.x.
  8. From the Edit menu, point to New and click DWORD Value and name it:

    Port

  9. Double-click the newly created value.
  10. In the Edit DWORD Value dialog box, under Value data, specify the TCP port that Laserfiche Server should use.
  11. Under Base, select Decimal.
  12. Click OK to save your changes.
  13. Restart the Laserfiche Server.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Scroll down and select Laserfiche Server 7.x.
    5. From the Action menu, click Restart.

Resolution 3

Make sure the path to the executable for the Laserfiche Server service is valid.

Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.

To view or edit the executable path for the Laserfiche Server service

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and then click OK to load the Windows Registry Editor tool:

    regedt32

  3. Expand HKEY_LOCAL_MACHINE.
  4. Expand SYSTEM.
  5. Expand CurrentControlSet.
  6. Expand Services.
  7. Click LFS7x.
  8. There should be an expandable string value named ImagePath.
  9. Verify that it is correctly pointing to where Laserfiche Server is installed. If it is not, modify the value.
  10. Restart the Laserfiche Server.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Scroll down and select Laserfiche Server 7.x.
    5. From the Action menu, click Restart.

SC.exe is a command line utility that can retrieve and set control information about services. This utility can be used to change the executable path of the Laserfiche Server service without using the Windows Registry Editor tool.

Note: The SC command line utility is only available on Windows XP and later.

To set the executable path for the Laserfiche Server service using the SC command line utility

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and click OK to load a command prompt window:

    cmd

  3. Type the following:

    sc config LFS7x binPath= "Path to LFS.exe"

    x is either 0 or 1 depending on whether you have Laserfiche Server 7.0 or 7.1. By default, the path should be C:\Program Files\Laserfiche\Server\LFS.exe.
  4. Restart the Laserfiche Server.

Resolution 4

Make sure the path to the Laserfiche shared system files is valid.

Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.

To view or edit the shared system files path for Laserfiche

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and then click OK to load the Windows Registry Editor tool.

    regedt32

  3. Expand HKEY_LOCAL_MACHINE.
  4. Expand SOFTWARE.
  5. Expand LASERFICHE.
  6. Click PathNT.
  7. There should be a string value named Path.
  8. Verify that it is correctly pointing to where the Laserfiche shared system files are installed. If it is not, modify the value. By default, the path should be C:\Program Files\Common Files\Laserfiche\System.
  9. Restart the Laserfiche Server.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Scroll down and select Laserfiche Server 7.x.
    5. From the Action menu, click Restart.

Resolution 5

You may have an incomplete installation. Repair the installation or reinstall the Laserfiche Server. In addition, be aware that Insufficient DCOM security settings can prevent Windows Installer from fully initializing. Please see the following Knowledge Base article for more information.

1000887 Insufficient DCOM Security Settings Can Prevent Laserfiche From Successfully Installing.

Resolution 6

If the Laserfiche Server is installed on Windows Server 2003, change the service to log on using a domain account with administrative privileges.

To modify the login account used by the Laserfiche Server service

  1. Click Start and then click Control Panel.
  2. Double-click Administrative Tools.
  3. Double-click Services.
  4. Locate and click Laserfiche Server 7.x.
  5. From the Action menu, click Properties.
  6. Click the Log On tab.
  7. Select the This account option.
  8. Specify a domain account with administrative privileges and the corresponding password for that account.
  9. Click OK to save your changes.
  10. Restart the Laserfiche Server.

Resolution 7

The Laserfiche Server requires certain files for proper operation. This error may arise when a required file (LFLic.ocx) is not properly registered on the computer hosting the Laserfiche Server.

To register LFLic.ocx

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and then click OK to register LFLic.ocx:

    regsvr32 "C:\Program Files\Common Files\LaserFiche\System\LFLIC.ocx"

  3. Restart the Laserfiche Server.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Scroll down and select Laserfiche Server 7.x.
    5. From the Action menu, click Restart.