Summary
When starting Laserfiche, it takes a long time for the Start Page to load the list of repositories.
Cause
By default, the Laserfiche Client listens for all repositories that are being broadcasted on the network. In certain network configurations or if there are simply a large number of repositories, this listening process can take a long period of time. See the following workaround to resolve this issue.
There is also another possible cause. Early prototypes of Laserfiche 7 included an auto-update feature. While this feature ultimately was not implemented for the release, the foundations of this feature were not fully removed before the release. In certain network configurations, this could significantly increase the amount of time needed for the Start Page to finish loading. See Resolution 1 or Resolution 2 to resolve this issue.
Resolution 1
This issue is resolved in Laserfiche Client 7.1. Please upgrade to the latest version of the Laserfiche Client.
Resolution 2
There is a hotfix available for Laserfiche 7.0.2 and 7.0.3. The fix is an updated version of LF.exe.
To update the Laserfiche Client
Workaround
Configure the Laserfiche Client to no longer listen for all repositories on the network. Instead the Client will simply use the list of repositories that have been manually attached to the Client.
Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.
To prevent the Client from listening for broadcasted repositories
regedt32
thunk
Note: Remember to manually attach the appropriate repositories from the Client Start Page.