Summary
After upgrading to Windows Server 2003, you may be unable to connect to a SQL database. This may occur in a variety of situations and it can be manifested with a variety of symptoms.
This issue can occur when the Laserfiche Server attempts to connect to a SQL database or when a local repository attempts to connect to a SQL database.
Cause
You may have an incorrect version of the Oledb32.dll file. This can occur if you upgraded from Windows 2000 to Windows Server 2003.
Workaround
The following workaround is taken from the Microsoft Knowledge Base article listed below.
Extract the compressed Oledb32.dll file from the Windows Server 2003 CD, and then copy the file to the following locations:
Note: <System Drive> is a placeholder for the root directory of the local drive on which Windows was installed.
More Information
For exact steps on how to extract and copy the Oledb32.dll file, please see the following Microsoft Knowledge Base article for more information: