Laserfiche Server Stops Working After You Upgrade to Windows Server 2003.

January 28, 2005 | KB: 1000873
Laserfiche 6, Laserfiche 7

Summary

After upgrading to Windows Server 2003, you may be unable to connect to a SQL database. This may occur in a variety of situations and it can be manifested with a variety of symptoms.

  • The Laserfiche Repository Creation wizard may return an ADODB connection error.
  • An ADODB connection error may occur when attaching a repository.
  • Your Laserfiche repository may not display in the list of repositories on the Client Start page.
  • You may receive the following error message: "The procedure entry point GetTextExtentPointI could not be located in the dynamic link library MSDART.DLL."

This issue can occur when the Laserfiche Server attempts to connect to a SQL database or when a local repository attempts to connect to a SQL database.

Cause

You may have an incorrect version of the Oledb32.dll file. This can occur if you upgraded from Windows 2000 to Windows Server 2003.

Workaround

The following workaround is taken from the Microsoft Knowledge Base article listed below.

Extract the compressed Oledb32.dll file from the Windows Server 2003 CD, and then copy the file to the following locations:

  • <System Drive>:\Program Files\common files\system\Ole db
  • %WINDIR%\system32\Dllcache

Note: <System Drive> is a placeholder for the root directory of the local drive on which Windows was installed.

More Information

For exact steps on how to extract and copy the Oledb32.dll file, please see the following Microsoft Knowledge Base article for more information:

The Oledb32.dll file is not upgraded when you upgrade your operating system from Windows 2000 to Windows Server 2003