Documents Created With Web Access or Quick Fields Are Not Routed.

February 4, 2005 | KB: 1000866
Workflow Suite 7

Summary

Documents created with Web Access or Quick Fields that satisfied rule criteria involving blank fields are not routed.

Cause

Work Distribution Agent treats empty fields differently depending on whether the empty field is a blank string or a NULL value. Empty fields on documents modified through the Laserfiche Client contain a blank string while empty fields on documents modified through Web Access or Quick Fields contain a NULL value.

Resolution 1

This issue is resolved in Laserfiche Workflow Suite 7.0.1. Please upgrade to the latest version of Workflow Suite.

Resolution 2

There is a hotfix available for Laserfiche Work Distibution Agent that will correctly take into account both types of blank fields.

  1. Click here to download a zip file containing an updated version of WorkDistribution.jar.
  2. Stop the Laserfiche Server Automation service
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Select Laserfiche Server Automation and from the Action menu, click Stop.
  3. Replace the WorkDistribution.jar found in the agents folder of your Server Automation installation folder with the WorkDistribution.jar included in the zip file. By default, it is located at C:\Program Files\Laserfiche\WorkflowSuite\ServerAutomation\Agents.
  4. Restart the Laserfiche Server Automation service.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Select Laserfiche Server Automation and from the Action menu, click Start.