A "[6512] Error opening repository." Error Occurs When Opening a Published Repository from CD.

January 14, 2005 | KB: 1000854
Plus 7.0.2

Summary

When you open a repository published to CD using Plus 7.0.2, the Login dialog box displays. When you click OK, you may receive the following error message:

    [6512] Error opening repository. Check log file for more information.

Cause

This issue arises when the published repository is stored on read-only media (e.g. CD, DVD, etc.). This will prevent you from opening the published repository directly from the CD or DVD.

Resolution

This issue is resolved in Laserfiche Plus 7.1 and later. Please upgrade to the latest version of Laserfiche Plus.

Workaround 1

There is a hotfix available for Laserfiche Plus 7.0.2. The fix is an updated version of LFENG.dll. This fix is included in LFENG.dll version 7.0.2.520 and later.

To update Laserfiche Plus

  1. Click here to download a zip file containing version 7.0.2.520 of LFENG.dll.
  2. Replace the LFENG.dll found in the Laserfiche Client installation folder with the LFENG.dll included in the zip file. By default, the Laserfiche Client is installed at C:\Program Files\Laserfiche\Client.
  3. Republish any desired repositories.

Note: Upgrading will not resolve this issue for any existing published repositories. You must either re-publish them or perform the following workaround.

Workaround 2

If you already have a repository that has been published on read-only media and you would like to open it, then you should copy the entire published repository to a folder on your computer. After which, you will be able to open the repository by simply running LFView.exe.