Searching Returns Invalid Search Results and Can Potentially Crash Laserfiche.

January 7, 2005 | KB: 1000851
Laserfiche 7

Summary

When performing a search, Laserfiche may return invalid search results. When this happens, the Laserfiche Server may become unstable. In turn, this will cause the Laserfiche client to lose its connection to the repository.

Cause

Laserfiche stores the size of each text file associated with a Laserfiche document in the SQL database. If the size stored in the SQL database does not match the actual size of the text file on your file system, then this issue may occur.

Resolution

This issue is resolved in Laserfiche 7.0.3 and later. Laserfiche Server will now correctly update the SQL table value if it detects that it is inconsistent with the actual value. Please upgrade to the latest version of Laserfiche.

Workaround

If you are using Laserfiche 7.0.2 and you do not wish to upgrade to the latest version, then you may apply a hotfix to your installation. The fix is an updated version of LFENG.dll. This fix is included in LFENG.dll version 7.0.2.510 and later.

To update the Laserfiche Server

  1. Click here to download a zip file containing version 7.0.2.510 of LFENG.dll.
  2. Replace the LFENG.dll found in the Laserfiche Server installation folder with the LFENG.dll included in the zip file. By default, the Laserfiche Server is installed at C:\Program Files\Laserfiche\Server.
  3. Restart the Laserfiche Server.
    1. Click Start and then click Control Panel.
    2. Double-click Administrative Tools.
    3. Double-click Services.
    4. Scroll down and select Laserfiche Server 7.x.
    5. From the Action menu, click Restart.