Summary
When performing a search, Laserfiche may return invalid search results. When this happens, the Laserfiche Server may become unstable. In turn, this will cause the Laserfiche client to lose its connection to the repository.
Cause
Laserfiche stores the size of each text file associated with a Laserfiche document in the SQL database. If the size stored in the SQL database does not match the actual size of the text file on your file system, then this issue may occur.
Resolution
This issue is resolved in Laserfiche 7.0.3 and later. Laserfiche Server will now correctly update the SQL table value if it detects that it is inconsistent with the actual value. Please upgrade to the latest version of Laserfiche.
Workaround
If you are using Laserfiche 7.0.2 and you do not wish to upgrade to the latest version, then you may apply a hotfix to your installation. The fix is an updated version of LFENG.dll. This fix is included in LFENG.dll version 7.0.2.510 and later.
To update the Laserfiche Server