A "The OCR engine was not found." Error Occurs When Calling the OCRDocument Method.

January 7, 2005 | KB: 1000850
Toolkit 6

Summary

When you call the OCRDocument LFAPI method, you receive the following error message:

    The OCR Engine was not found.

Cause

This error can occur if LFOCRCom.dll isn't properly registered.

Resolution

Perform the following steps to resolve this issue:

  • Make sure that C:\Program Files\Common Files\LaserFiche\Batch Processor\LFOCR\LFOCRCom.dll exists and that it has been properly registered.
  • If you are using or would like to use the Expervision OCR engine, then you should reinstall the Laserfiche client (version 6.0x).
  • If you are using the IRIS OCR engine, then you should update your system to allow the OCRDocument method to use the IRIS OCR engine. Download the following registry file that will update LFOCRCOM to use IRIS: IRIS_Update.reg. After downloading the registry file, run it from the computer that is experiencing this issue. When prompted, confirm that your registry will be updated with the information stored in the registry file.

To register a dll file

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following to register the file:

    regsvr32 C:\Program Files\Common Files\Laserfiche\Batch Processor\LFOCR\LFOCRCom.dll