A "The Laserfiche Server encountered an error when trying to attach the repository. Error 7826." Error Occurs When Attaching a Repository.

December 27, 2004 | KB: 1000844
Server (MSDE) 7, Server (MSSQL) 7

Summary

When attempting to attach a repository in the Laserfiche Administration Console, the following message occurs:

    The Laserfiche Server encountered an error when trying to attach the repository. Error 7826.

Cause

The Laserfiche Server was unable to open the index (.IDX) files in the SEARCH folder. The search index files associated with that repository may be corrupted.

Workaround

Delete the search index files associated with that repository and then try attaching the repository. The search index files can be found in the Search folder, which is located under the base folder of your Laserfiche repository. The search index files will be recreated when the repository is successfully attached to the Laserfiche Server.

This procedure will cause you to lose text indexing and any changes made to the index configuration. Therefore, you will need to reindex your repository, including unmounted volumes, after the repository is attached.