Summary
Deleting documents in large repositories can be slow and processor intensive.
Cause
The trigger for entry deletions was not optimized.
Resolution
This issue is resolved in Laserfiche 7.0.3 and later. Please upgrade to the latest version of Laserfiche.
Note: The Laserfiche 7.0.3 upgrade process does not upgrade the SQL schema for preexisting databases. This means that new repositories created after upgrading to Laserfiche 7.0.3 will have the updated trigger, but existing repositories will not. The trigger must be manually updated for existing repositories. Please see the following workaround.
Workaround
Download and run a SQL script that updates the trigger in existing repositories.
Note: This update script should not be used with an Oracle database.
To update a SQL database's triggers
cmd
OSQL -S SQLInstance -E -d DatabaseName -i "PathtoScript"
DatabaseName is the name of the SQL database associated with your repository. PathtoScript is the location of hotfix_SCR18024.sql.SQL Server Instance (Laserfiche Server Team): The SQL Server instance name will be the name of the computer hosting the Laserfiche Server followed by a backslash and then the word "LASERFICHE." For example, if your server name is "Computer," then the corresponding SQL Server instance name is "Computer\LASERFICHE."
SQL Server Instance (Standalone): The SQL Server instance name will be the name of the computer where the local repository resides followed by a backslash and then the word "LASERFICHE." For example, if your computer name is "Computer," then the corresponding SQL Server instance name is "Computer\LASERFICHE."