Summary
After upgrading to Laserfiche Server 7.0.2 or later, the Laserfiche Client Start Page does not display any of your existing version 7.0 or 7.0.1 repositories. If you try to register the repository using the Laserfiche Administration Console or try to attach the repository from the Laserfiche Client Start Page, you may receive the following error message:
This version of the server is incompatible with the specified repository. [7020]
Cause
Laserfiche Server 7.0.2 and later does not directly support Laserfiche 7.0 or 7.0.1 repositories. Previous Laserfiche 7 repositories must first be updated for use with Laserfiche Server 7.0.2 or later.
Resolution
Upgrade all repositories using the Laserfiche Repository Upgrade Utility. This can be performed by following the steps listed in the To upgrade a Laserfiche Server to the latest version procedure.
The Laserfiche Repository Upgrade Utility can only upgrade registered Laserfiche repositories. If you unregistered a repository prior to upgrading to Laserfiche 7.0.2, then you must either manually register the repository, or perform the following steps:
To upgrade a Laserfiche repository to the latest version
More Information
In Laserfiche 7.0.2, the Laserfiche Repository Upgrade Utility is only installed when the Laserfiche Server is upgraded using the patch. If the Laserfiche Server was uninstalled prior to upgrading to the latest version, then you can force the installation to install the utility by using the following command-line prompt: setup.exe /v"ADDLOCAL= UpgradeReg".
See the following Laserfiche Knowledge Base article for information on how to manually register a Laserfiche repository:
1000863 Manually Registering a Laserfiche Repository.