A "Cannot export volume to a non-empty directory. [7602]" Error Occurs When Detaching a Volume.

March 28, 2005 | KB: 1000799
Laserfiche 7

Summary

When you detach a volume to its fixed path, you may receive the following error message:

    Cannot export volume to a non-empty directory. [7602]

Cause

This error occurs when the fixed volume path stored in the SQL database contains a trailing backslash (\). When the Laserfiche Administration Console retrieves the value of the volume path, it truncates the backslash. When detaching to a volume's fixed path, the two values for the path do not match and the detach process fails.

Workaround

Detach the volume to another location. If you want to detach the volume to its fixed path, you must modify the volume's path value in the SQL database to remove the trailing backslash before detaching.

To modify a volume's path value using OSQL

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and click OK to load a command prompt window:

    cmd

  3. Type the following and press ENTER to load OSQL:

    OSQL -S SQLInstance -E

    SQL Server Instance (Laserfiche Server Team): The SQL Server instance name will be the name of the computer hosting the Laserfiche Server followed by a backslash and then the word "LASERFICHE." For example, if your server name is "Computer," then the corresponding SQL Server instance name is "Computer\LASERFICHE."

    SQL Server Instance (Standalone): The SQL Server instance name will be the name of the computer where the local repository resides followed by a backslash and then the word "LASERFICHE." For example, if your computer name is "Computer," then the corresponding SQL Server instance name is "Computer\LASERFICHE."

  4. Type the following to modify the path value:

    USE DatabaseName
    UPDATE Vol set FixedPath='PathWithoutTrailingBackslash' where VolumeName='VolumeName'
    GO

  5. Type EXIT to quit the utility.
  6. Restart the Laserfiche Server before detaching.