Preventing the Laserfiche 7 Client from Displaying Old Repositories.

December 19, 2005 | KB: 1000768
Laserfiche 7

Summary

After upgrading your Laserfiche client from version 6 to version 7, old repositories are still displayed in the Laserfiche Start page.

Cause

When Laserfiche Client 7 is opened for the first time, it locates and copies the contents of the current Windows user's LF.ini file into the HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile registry key. This includes the IPDatabase settings.

Resolution 1

Laserfiche clients 7.1.2 and later now allow you to unregister a selected repository directly from the Start page. Right-click the desired repository and select Remove selected repository to remove the associated information from the client computer's registry and LF.ini file.

Resolution 2

Remove any outdated values from the HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile\IPDatabase key and the LF.ini files.

To modify the IPDatabase key

  1. Click Start and then select Run.
  2. Type the following and click OK to load the Windows Registry Editor:

    regedt32

  3. Expand HKEY_CURRENT_USER.
  4. Expand Software.
  5. Expand Laserfiche.
  6. Expand Client.
  7. Expand Profile.
  8. Click IPDatabase.
  9. Select the desired repositories listed in the right-hand pane.
  10. From the Edit menu, click Delete.

Note: This procedure will only remove old repositories for the user currently logged into Windows.

To modify the LF.ini files

  1. From a text editor, open the LF.ini file. The LF.ini file exists in two locations:
    • C:\Documents and Settings\UserName\Application Data\Lf
    • C:\Windows or C:\WINNT
  2. Locate the IPDatabase section in the file.
  3. Delete the outdated repository values.
  4. Save your changes and close the file.