Summary
The installation for the MSDE instance for Laserfiche 7 will fail with very little information when MSDE data files from a previous MSDE instance exist.
Cause
Uninstalling MSDE does not remove existing data files. The MSDE installation for Laserfiche 7 cannot successfully complete if data files exist in the C:\Program Files\Microsoft SQL Server\MSSQL$LASERFICHE\Data folder.
Workaround
Rename the existing data files in C:\Program Files\Microsoft SQL Server\MSSQL$LASERFICHE\Data or move them to a temporary location. You should then install the MSDE instance provided for Laserfiche 7.