A "6000 (null)" Error Occurs When Using the Send to Laserfiche Menu Option from Microsoft Word.

August 7, 2014 | KB: 1000756
Laserfiche 7

Summary

When using the Send to Laserfiche menu option from Microsoft Word, you receive the following error message:

    6000 (null)

Note: Although sending a Word document to Laserfiche generates an error, a Laserfiche document is still created.

Cause

This issue is caused by a version mismatch in the LFOffice.dll file included with Laserfiche 7.0.1.

Resolution

To resolve this issue, please upgrade Laserfiche to version 7.0.2.

Workaround

Download and replace the LFOffice.dll file with an updated version from the Laserfiche FTP site.

To update your LFOffice.dll file

  1. Click here to download the LFOffice.dll file to a temporary location.
  2. Browse to the C:\Program Files\Common Files\Laserfiche\LFOffice folder.
  3. Remove the existing version of LFOffice.dll.
  4. Move the downloaded version from the temporary location to C:\Program Files\Common Files\Laserfiche\LFOffice.
  5. Register the new version of the dll:
    1. Click Start and then click Run.
    2. In the Run dialog, type the following and click OK to register LFOffice.dll:

      regsvr32 C:\Program Files\Common Files\Laserfiche\LFOffice\LFOffice.dll