Summary
When launching Laserfiche Scanning, you may receive the following error messages:
Cannot initialize Laserfiche Scanning
Failed to create LFAPIcom70 object
Cause
When initializing a scanner, Laserfiche Scanning waits a set amount of time before timing out. An issue arises when scanners take longer to initialize than Laserfiche Scanning is willing to wait. In such a case, Laserfiche Scanning will time out. See Resolution 1 for information on modifying the timeout limit.
This issue can also arise if the Laserfiche Admin user does not have a password. See Resolution 2 for information on using the Laserfiche Administration Console to set a password.
Resolution 1
You can now define how long you wish Laserfiche Scanning to wait for a scanner to initialize. This can be performed by creating and modifying the following registry value: HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile\Settings\ScanStartTimeout. This registry value controls how long Laserfiche Scanning will wait for a scanner to initialize before returning a timeout error. The value is specified in milliseconds and the default value is 20000.
Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.
To create and modify the registry value
regedt32
Resolution 2
Assign a password to the Laserfiche Admin user account.
To assign a password to the Admin user