A "Cannot initialize Laserfiche Scanning" Error Occurs When Launching Laserfiche Scanning.

November 16, 2004 | KB: 1000748
Laserfiche 7

Summary

When launching Laserfiche Scanning, you may receive the following error messages:

    Cannot initialize Laserfiche Scanning

    Failed to create LFAPIcom70 object

Cause

When initializing a scanner, Laserfiche Scanning waits a set amount of time before timing out. An issue arises when scanners take longer to initialize than Laserfiche Scanning is willing to wait. In such a case, Laserfiche Scanning will time out. See Resolution 1 for information on modifying the timeout limit.

This issue can also arise if the Laserfiche Admin user does not have a password. See Resolution 2 for information on using the Laserfiche Administration Console to set a password.

Resolution 1

You can now define how long you wish Laserfiche Scanning to wait for a scanner to initialize. This can be performed by creating and modifying the following registry value: HKEY_CURRENT_USER\Software\Laserfiche\Client\Profile\Settings\ScanStartTimeout. This registry value controls how long Laserfiche Scanning will wait for a scanner to initialize before returning a timeout error. The value is specified in milliseconds and the default value is 20000.

Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.

To create and modify the registry value

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following to load the Windows Registry Editor utility.

    regedt32

  3. Expand KEY_CURRENT_USER.
  4. Expand Software.
  5. Expand Laserfiche.
  6. Expand Client.
  7. Expand Profile.
  8. Click Settings.
  9. From the Edit menu, point to New and select String Value.
  10. Name the value: ScanStartTimeout.
  11. Double-click the value to load the Edit String dialog.
  12. Enter the desired value.

Resolution 2

Assign a password to the Laserfiche Admin user account.

To assign a password to the Admin user

  1. Load the Laserfiche Administration Console by clicking Start, pointing to All Programs, Laserfiche, and then clicking Laserfiche Administration Console.
  2. Expand the appropriate Laserfiche Server.
  3. Expand the Repositories node.
  4. Expand the appropriate Laserfiche repository.
  5. Expand the Users and Groups node.
  6. Select the Users node.
  7. Click the Admin user account.
  8. From the Action menu, click Properties to load the User Properties dialog box.
  9. In the General tab, specify a password in the appropriate fields.
  10. Click OK to save your changes and close the dialog box.