Summary
When you attempt to log in to a repository, you may receive the following error message:
Error 6000: Unknown Error
Cause
The possible causes for this error are listed below:
Start the Laserfiche Server service.
Re-register LaserficheServerObjects.dll (Laserfiche 7.0.x), LFSO71.dll (Laserfiche 7.1.x), LFSO72.dll (Laserfiche 7.2.x), LFCommonDialogs72.dll (Laserfiche 7.2.x), LfDocInterfaces72.dll (Laserfiche 7.2.x), and LFEngPS.dll.
regsvr32 "C:\Program Files\Common Files\Laserfiche\LFObjects\LaserficheServerObjects.dll"
regsvr32 "C:\Program Files\Common Files\Laserfiche\LFObjects\LFSO71.dll"
regsvr32 "C:\Program Files\Common Files\Laserfiche\LFObjects\LFSO72.dll"
regsvr32 "C:\Program Files\Common Files\Laserfiche\Controls\LFCommonDialogs72.dll"
regsvr32 "C:\Program Files\Common Files\Laserfiche\Controls\LfDocInterfaces72.dll"
regsvr32 "C:\Program Files\Common Files\Laserfiche\LFObjects\LFEngPS.dll"
For more information on configuring Windows 2000, Windows XP (Service Pack 2), or Windows Server 2003 (Service Pack 1) with Laserfiche and configuring DCOM security, please refer to the following articles.
1000710 Configuration Information for Laserfiche Server (Version 7) and Windows XP (Service Pack 2) or Windows Server 2003 (Service Pack 1).
1000985 Configuring DCOM for Laserfiche Server 7 and Windows 2000.
For more information on enabling DCOM on a Laserfiche client workstation, please refer to the following article.
1011029 Enabling DCOM for Laserfiche Client 7