Your Laserfiche Repository Does Not Display After You Restart the Computer.

June 3, 2005 | KB: 1000713
Server (MSDE) 7, Server (MSSQL) 7

Summary

After restarting the computer hosting the Laserfiche Server, your Laserfiche repository does not display in the Client Start Page.

Cause

Laserfiche Server and Microsoft SQL Server are installed on the same computer and the Laserfiche Server is attempting to connect to a database before Microsoft SQL Server has finished loading.

Resolution

This issue is resolved in Laserfiche 7.2. Laserfiche Server will now wait until the local Microsoft SQL Server instance is loaded before connecting to a SQL database.

Workaround

A workaround for this issue is to make sure that the Laserfiche Server is dependent on Microsoft SQL Server. Additionally, to ensure that all databases have been loaded by SQL Server, you should create a delay before the Laserfiche Server will try to connect to SQL databases.

Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.

To add a dependency setting to the Laserfiche Server

See the following Laserfiche Knowledge Base article:

INFO: Setting Service Dependency for the Laserfiche Server.

Note: The dependency setting is only valid when Laserfiche Server and Microsoft SQL Server are installed on the same computer. Do not configure Laserfiche Server with a dependency setting if Laserfiche Server and Microsoft SQL Server are installed on separate computers.

To add the Start Pause DWORD value to the registry

  1. Click Start and then click Run.
  2. In the Run dialog box, type the following and click OK to load the Windows Registry Editor:

    regedt32

  3. Expand My Computer.
  4. Expand HKEY_LOCAL_MACHINE.
  5. Expand SOFTWARE.
  6. Expand LASERFICHE.
  7. Expand Engine.
  8. Click 7.x.
  9. From the Edit menu, point to New and click DWORD Value.
  10. Name the value:

    Start Pause

  11. Make sure Start Pause is selected and from the Edit menu, click Modify.
  12. In the Edit DWORD Value dialog box, under the Base section, select the Decimal option.
  13. In the Value data field, specify the amount of time you wish to wait before allowing Laserfiche Server to start. The value is in milliseconds. For example, to set a 10 second delay, set the value to 10000.
  14. Click OK to save the value.