Summary
After restarting the computer hosting the Laserfiche Server, your Laserfiche repository does not display in the Client Start Page.
Cause
Laserfiche Server and Microsoft SQL Server are installed on the same computer and the Laserfiche Server is attempting to connect to a database before Microsoft SQL Server has finished loading.
Resolution
This issue is resolved in Laserfiche 7.2. Laserfiche Server will now wait until the local Microsoft SQL Server instance is loaded before connecting to a SQL database.
Workaround
A workaround for this issue is to make sure that the Laserfiche Server is dependent on Microsoft SQL Server. Additionally, to ensure that all databases have been loaded by SQL Server, you should create a delay before the Laserfiche Server will try to connect to SQL databases.
Warning: Incorrectly editing the registry may adversely affect your system. Before you edit the registry, make sure you understand how to restore it if a problem occurs.
To add a dependency setting to the Laserfiche Server
See the following Laserfiche Knowledge Base article:
INFO: Setting Service Dependency for the Laserfiche Server.
Note: The dependency setting is only valid when Laserfiche Server and Microsoft SQL Server are installed on the same computer. Do not configure Laserfiche Server with a dependency setting if Laserfiche Server and Microsoft SQL Server are installed on separate computers.
To add the Start Pause DWORD value to the registry
regedt32
Start Pause