An "Error: Could not find object" Error Occurs When Using Quick Fields.

July 19, 2005 | KB: 1000677
Quick Fields 6.2

Summary

When processing documents in Quick Fields, you may receive the following error message:

    Error: Could not find object

Cause

The Laserfiche Client contains a "Use name parsing" option under the Autoname Options. When enabled, processing in Quick Fields may rename a folder in the path to which documents will be stored. When this issue affects the root folder, there will be no visible indication that it has been renamed.

Resolution

Download an updated version of the LFAPICOM61.dll file to prevent future occurrences of this issue. Rename the root folder back to its original name to resolve the issue.

To update LFAPICOM61.dll:

  1. Click hereto download LFAPICOM61.dll.
  2. Replace the existing file in C:\Program Files\Common Files\Laserfiche\LFAPI.
  3. Manually register the new LFAPICOM61.dll file.
    1. Click Start and click Run.
    2. Type the following to register the LFAPICOM61.dll.

      regsvr32 C:\Program Files\Common Files\Laserfiche\LFAP\lfapicom61.dll

    3. Click OK.

To rename the root folder in the TOC table:

  1. Click here to download the UpdateRoot.vbs script.
  2. Double-click the file to run the script.
    1. In the first dialog box, specify the name of the computer hosting Microsoft SQL Server and click OK.
    2. In the second dialog box, specify the name of the SQL database and click OK.

Note: In certain cases, this particular issue can rename folders other than the root folder. If this should happen, the UpdateRoot.vbs script file may not resolve your issue. If the issue persists after running the script file, please contact Laserfiche Technical Support to obtain help in tracking down the folder that was renamed.