A "[7050] Open database failed: Canot generate SSPI context." Error Occurs When Creating a New Repository.

March 7, 2005 | KB: 1000676
Laserfiche 7

Summary

NT AUTHORITY\System When you create a new repository, you may receive the following error message:

    Open database failed. Cannot generate SSPI context

Cause

There is a security issue with Windows Authentication. The Laserfiche Server needs to log in as a domain account.

Resolution

Setup the Laserfiche Server to log in as a domain account with the privilege to write to the hard disk.

To change Windows accounts:

  1. Click Start and click Control Panel.
  2. Double-click Administrative Tools.
  3. Double-click Services.
  4. Scroll down and click Laserfiche Server 7.0.
  5. From the Action menu, click Properties.
  6. Click the Log On tab.
  7. Choose "This account" and enter a Windows domain account name with sufficient rights to write to the hard disk.
  8. Enter the appropriate password.
  9. Click OK.
  10. Restart the Laserfiche Server 7.0 service. To accomplish this, select the Laserfiche Server and then click Restart from the Action menu.