A "The Pervasive.SQL engine cannot be found [7039:0]" Error Occurs When Attaching a Volume.

February 9, 2006 | KB: 1000663
Laserfiche 6, Laserfiche 7

Summary

When attaching a volume exported from Laserfiche 5 to a Laserfiche 6 repository, you may receive the following error message:

    The Pervasive.SQL engine cannot be found [7039:0]

When attaching a volume exported from Laserfiche 5 to a Laserfiche 7 repository, you may receive the following error message:

    The SQL Database Engine(BTRIEVE) has encountered an unexpected error and is unable to continue. Check error log for more information. [7030]"

Cause

In order to attach Laserfiche 5 volumes to a Laserfiche 6 or Laserfiche 7 repository, the computer hosting the Laserfiche Server or the workstation hosting the local repository must have the Pervasive.SQL 2000 database engine installed.

Resolution

Install Pervasive.SQL 2000 on the computer hosting the Laserfiche Server or the workstation hosting the local repository.

To install the Pervasive.SQL 2000 database engine:

  1. Visit the Laserfiche FTP site and download the following files:
  2. Extract the contents of Pervasive_wse_sp3.zip to a temporary location and run the installation to install Pervasive.SQL 2000 Service Pack 3.
  3. After installing Pervasive.SQL 2000 Service Pack 3, double-click PSQL2Ki_SP4_WSE.exe to update to Pervasive.SQL 2000 Service Pack 4.

Note: After installing the Pervasive engine, try reattaching the volume.