A "[7.3092] Could not find stored procedure 'lfsp_update_tables'" Error Occurs when Opening or Attaching a Database.

July 18, 2005 | KB: 1000658
Laserfiche 6, Plus 6

Summary

When you open or attach a database, you may receive the following error in the Event Viewer:

    [7.3092] Could not find stored procedure 'lfsp_update_tables'

Cause

The stored procedures were not updated after upgrading the Laserfiche Server.

Resolution

The Laserfiche Server uses stored procedures to access database data. This issue may arise when the stored procedures do not get updated after upgrading the Laserfiche Server.

To update stored procedures using a VBScript:

  1. Click here to download the necessary script.
  2. Double-click the file to begin running the script.
  3. From the first Laserfiche dialog box, type the name of the computer where the SQL server resides. Click OK.

    Note: If you are using Laserfiche Group, then you should append the following to the computer name: \Laserfiche.

  4. From the second Laserfiche dialog box, type in the name of the SQL database associated with the Laserfiche database in question. Typically, the SQL database name is the same as the Laserfiche database name. Click OK.
  5. Click "Yes" when asked to update.
  6. Restart the Laserfiche for Microsoft SQL Server service.

Note: This script resets the current stored procedure version number to "1." Restarting Laserfiche will now automatically update the stored procedures.