After Installing Snapshot, the Client Does Not Contain an Option to Start LFAssist.

June 21, 2004 | KB: 1000613
Snapshot 6

Summary

After installing Snapshot, there is no menu option to start LFAssist.

Cause

The installation did not install the files needed for LFAssist. This error can occur if the Snapshot installation does not see that the Client is installed, or installs the files to the incorrect installation of the client. Files can be installed to the incorrect client installation when more than one version of the Client has been installed.

Resolution

Check that the CurrentVersion registry string is set to the correct value before reinstalling Snapshot.

  1. Click Start and then click Run.
  2. Type the following to start the Windows Registry Editor.

    regedt32

  3. Expand My Computer.
  4. Expand HKEY_LOCAL_MACHINE.
  5. Expand SOFTWARE.
  6. Expand LASERFICHE.
  7. Select Client.
  8. Check that the CurrentVersion string contains the correct value for which version you want to install Snapshot to.
  9. If you would like to change what Client installation the Snapshot installation will look for, modify the value of the CurrentVersion string to the desired value.
    1. Click CurrentVersion.
    2. From the Edit menu, click Modify.
    3. Type in the desired value.

More Information

The Snapshot installation looks in the HKEY_LOCAL_MACHINE\SOFTWARE\LASERFICHE\Client\ key for the CurrentVersion string. The installation then looks in the HKEY_LOCAL_MACHINE\SOFTWARE\LASERFICHE\Clie nt\x.x registry key for the install path of the Client, where x.x is the value of the CurrentVersion string. If this InstallPath value does not exist or is incorrect, Snapshot will not install the files required by the Client for LFAssist.