Summary
LaserFiche locks documents in unwarranted situations.
Cause
A document is locked whenever a user is modifying data. This prevents the changes performed by one user from being overwritten by another user. LaserFiche version 6.1 changed the manner in which documents are locked for writing. This caused documents to be locked in unwarranted situations. One example of incorrect document locking occurs for newly scanned documents. Another example occurs when a new document is created using the remaining pages in the source document. The source document would remain locked after its pages were removed from it.
Resolution
Upgrade to LaserFiche 6.11 to resolve this issue.
More Information
A hotfix was released to resolve this issue in LaserFiche Server 6.1. The hotfix was incorporated into LaserFiche Server 6.11. Document locking behavior in LaserFiche 6.11 is now less restrictive.
Note: Be aware that this behavior has less control of locking documents. For example, when two or more users are editing a list field on the same document, LaserFiche will save the field changes made by the last person to close that document. Changes made by any other user while the document was still open will be lost.