MSDE Fails to Install.

May 10, 2004 | KB: 1000559
Laserfiche 6, Plus 6

Summary

The MSDE installation proceeds until it is almost finished. However, the installation unexpectedly rolls back and fails.

Cause

The MSDE installation may fail because a necessary service is not installed. MSDE requires the Server service to be installed and running. The Server service requires that File and Printer Sharing for Microsoft Networks also be installed.

  1. The Server service is not running.
  2. The Server service is not installed on your computer. This can occur if File and Printer Sharing for Microsoft Networks is not installed or if File and Printer Sharing for Microsoft Networks is installed, but is disabled.

Resolution

The following resolution is taken from the Microsoft Knowledge Base article listed in the More Information section.

Check to see if the Server service is installed and running. Then reinstall the MSDE from the LaserFiche Client CD.

To check if the Server service is installed:

  1. Click Start and click Control Panel.
  2. Double-click on Administrative Tools.
  3. Double-click on Services.
  4. Scroll down and find the Server service.
  5. If the service is running, stop and then restart it.
    1. Select Server.
    2. From the Action menu, click Restart.
  6. If the service is not running, start it.
    1. Select Server.
    2. From the Action menu, click Start.
  7. If the service is not displayed in the list of services, enable or install File and Printer Sharing for Microsoft Networks.

To check if File and Printer Sharing for Microsoft Networks is installed:

  1. Click Start and click Control Panel.
  2. Double-click Network Connections.
  3. Double-click on Local Area Connection
  4. In the Local Area Connection Status dialog box, click on Properties.
  5. In the "This connection uses the following items:" box, look for File and Printer Sharing for Microsoft Networks.
  6. If File and Printer Sharing for Microsoft Networks is listed, but the check box is cleared, this component is installed but disabled. To enable it:
    1. Click the check box next to File and Printer Sharing for Microsoft Networks.
    2. Click Close to finish.
  7. If File and Printer Sharing for Microsoft Networks is not listed, this component is not installed.

To install File and Printer Sharing for Microsoft Networks:

  1. From the Local Area Connection Properties dialog box, click Install.
  2. In the Select Network Component Type dialog box, click Service and click Add.
  3. In the Select Network Service dialog box, click File and Printer Sharing for Microsoft Networks and click OK.
  4. Back at the Local Area Connection Properties dialog box, click Close to finish.

Install MSDE from the LaserFiche Client Installation CD:

  1. Insert the LaserFiche Client Installation CD.
  2. Browse to the MSDE directory.
  3. Double-click to run LF6InstallTail.exe.

More Information

For more information, click the following Microsoft Knowledge Base article:

313939 When You Try to Install Microsoft Data Engine, the Installation Nearly Completes and Then Rolls Back.