The MSDE Installation Generates a SA Password Error When Installing From a Published CD.

August 6, 2014 | KB: 1000508
Laserfiche 6, Plus 6

Summary

When you attempt to install MSDE, you may receive the following error message:

    A strong SA password is required for security reasons. Please use SAPWD switch to supply the same. Refer to readme for more details. Setup will now exit.

Cause

This error occurs when attempting to view a published LaserFiche database on a computer that does not have MSDE installed. Since MSDE is a required component for viewing a LaserFiche database, the CD will attempt to install MSDE.

This issue arises during the end of the installation when it attempts to start the Desktop Engine. The installation will fail because the current user does not have sufficient Windows user rights to log on to the Desktop Engine. Since SQL Server authentication is not enabled by default, the user also cannot access the SQL Server using an account name and password. The resolution is to modify the MSDE installation to enable mixed mode authentication. Perform one of the following workarounds:

  1. Download and use an updated installation file to reinstall MSDE. See Workaround 1.
  2. Edit a SQL Server registry value to enable mixed mode authentication. See Workaround 2.

Workaround 1

The LaserFiche 6.11 MSDE installation executable resolves this issue. If you are using an earlier version of Laserfiche, download and use an updated LF6INSTALLTAIL.exe file from the LaserFiche FTP server.

To reinstall MSDE using an updated LF6INSTALLTAIL.exe:

  1. Click here to download LFINSTALLTAIL.zip.
  2. Extract the contents to a temporary directory.
  3. In the C:\Program Files\LaserFiche\LFW\MSDE folder, replace the LF6INSTALLTAIL.exe file with the extracted version.
  4. Republish and distribute the database.
  5. If you are unable to publish a new CD with the updated LF6INSTALLTAIL.exe file, perform the following:
    1. Browse the contents of the published CD.
    2. In the DBEngine folder, copy the MSDE folder to the hard disk of the computer you want to view the published database on.
    3. In the MSDE folder, replace the LF6INSTALLTAIL.exe file with the downloaded version.
    4. Double-click LF6INSTALLTAIL.exe to install MSDE.

Workaround 2

This issue can be resolved without repeating the MSDE installation. Mixed mode authentication can be manually enabled through the registry.

To edit the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\LASERFICHE\MSSQLServer registry key's LoginMode registry string:

  1. Click Start and then click Run to open the Run dialog box.
  2. In the Open text box, type "regedt32" and click OK.
  3. In the Registry Editor, expand My Computer.
  4. Expand HKEY_LOCAL_MACHINE.
  5. Expand SOFTWARE.
  6. Expand Microsoft.
  7. Expand Microsoft SQL Server.
  8. Expand LASERFICHE.
  9. Click the MSSQLServer key.
  10. In the details pane, double-click LoginMode.
  11. Change the value to 0 and click OK.