Summary
When you open a document or view a field, you may receive the following error message:
7180: Could not find template data.
Cause
This error most commonly occurs after migrating the database. An error occurred during the migration process and one of the TD tables migrated with an incorrect column name. The TD table should have a column named TocId instead of Id.
Resolution
Rename the Id column of each TD table to TocId. This can be accomplished using either Enterprise Manager or the OSQL command line utility. Perform one of the following methods:
Note: Enterprise Manager is only available if you have the full version of Microsoft SQL Server. If you are using MSDE, perform the second method involving the OSQL command line utility.
To rename the Id column using Microsoft SQL Server Enterprise Manager:
To rename the Id column using the OSQL command line utility:
cmd
osql -E -S ComputerName\LaserFiche -d "Database_Name"
Note: If you are using LaserFiche United (Standard\Enterprise), then you should only specify the name of the computer where the SQL server resides.
SELECT TableName FROM TSTR
GO
EXEC sp_rename 'TD1.[Id]', 'TocId', 'COLUMN'
GO