A "7023: Database not found" Error Occurs When Opening or Attaching a Database

March 23, 2004 | KB: 1000382
Laserfiche 6, Plus 6

Summary

When you attach or open a database, you may receive the following error message:

    7023: Database not found

Cause

There are a number of causes for this particular error and they are listed as follows:

  1. The LaserFiche for Microsoft SQL Server service may be starting before the MSDE service or the Microsoft SQL Server service. See Resolution 1.
  2. The database index (.idx) files may be corrupted. See Resolution 2.

Resolution 1

There may be an incorrect or missing setting in the registry. The LaserFiche for Microsoft SQL Server service is starting up before the required MSDE or SQL Server service.

For detailed instructions on editing the LaserFiche for Microsoft SQL Server registry key, click on the article below:

1000446 Editing the DependOnService Registry String

Resolution 2

If your database index files are corrupted, you will need to delete them. After clearing out the old index information, you will need to rebuild your search index information.

To recreate your search indexing:

  1. Delete your search index files. These files have an .idx extension and can be found in the Search directory that is located in your database directory.
  2. From the LaserFiche Client, click the Tools menu and select Reindex Searchbase.
  3. Make sure that the Reindex all documents which contain text option is selected.
  4. Click OK.