A "7390: Document or folder locked by another user." Error Occurs When Building Documents From a Batch or Modifying a Document.

July 18, 2005 | KB: 1000381
Laserfiche 6, Plus 6, Scanning 6

Summary

When building documents out of a batch or modifying a document, you may receive the following error message:

    7390: Document or folder locked by another user.

Cause

As a versioning safeguard, documents are locked while users are working on them. This functionality can cause error 7390 in two common situations. They are listed as follows:

  1. This error can occur when locked documents are not unlocked after a user has finished working. This situation is a known issue with LaserFiche versions 6.04 and 6.1. See the following Resolution.
  2. As a part of LaserFiche's normal behavior, error 7390 can occur when you attempt to modify a document that is currently in use by another user. See the Workaround.

Resolution

This issue is resolved in LaserFiche 6.11. Please upgrade to the latest version of Laserfiche 6.

Note: Be aware that LaserFiche 6.11 and later has less control of locking documents. For example, when two or more users are editing drop-down list fields on the same document's list field template at the same time, LaserFiche will save the template changes made by the last person to close the document. Changes made by any other user while the document was still open will be lost.

Workaround

Close the document on any other LaserFiche Client\Viewer stations. Try again.