A "7443: Unknown Error" Error Occurs When Opening a Document

May 21, 2004 | KB: 1000380
Audit Trail 6

Summary

When you open a document, you may receive the following error message:

    7443: Unknown error

Cause

Audit Trail has encountered an error while writing to the log. There are two common causes for this particular error and they are listed as follows:

  1. Audit Trail could not find or create the log file. See Resolution 1.
  2. The Audit Trail XML file has grown too large. See Resolution 2.

Resolution 1

The location setting for the log file may be missing or invalid.

To update the Audit Trail log file location setting:

  1. Start Audit Trail.
  2. Click on the Logging link.
  3. In the Log directory text field, note the current setting
  4. If an invalid path has been specified, please specify the desired location for the log file. When specifying a log file location, keep in mind that the location is relative to the computer hosting the LaserFiche Server.

Resolution 2

Audit Trail may not be able to write to the log file when the file size exceeds 1 gigabyte (GB). When this occurs, you can rename the existing log file. This will allow new events to be recorded. Additionally, you should configure the maximum log file size to prevent this issue from reoccurring.

To change the log file settings:

  1. Rename the XML log file. This will cause Audit Trail to start a new log file.
  2. Load the Audit Trail Monitor administration site.
  3. Click the Archiving link in the site toolbar.
  4. Set the Maximum log file size. Choose a value below 1 GB.
  5. Click Update to save the changes.