A "6520: Time-out for operation call." Error Occurs When Using the LaserFiche Client

May 12, 2014 | KB: 1000306
Laserfiche 6

Summary

When you perform disk-heavy operations on the server, you may receive the following error message:

    6520: Time-out for operation call. The server did not respond correctly to the last function call.

Cause

This error is commonly associated with a network communication failure. The LaserFiche Client loses communication with the LaserFiche Server and times out.

Workaround 1

Install the latest patch for your LaserFiche product. Check the LaserFiche website at http://www.laserfiche.com/services/updates.html for information on the latest patches.

Workaround 2

Edit the LaserFiche LF.ini file to increase the timeout limit.

  1. From a text editor, open the LF.ini file. See the More Information section for information on the location of the LF.ini file for your particular operating system.
  2. Under the [System] section, add or modify the following line:

    LFSockTimeout=600

    The value of LFSockTimeout is set in seconds. For example, a value of 600 will set the time-out limit to 10 minutes.

Workaround 3

Note: This workaround only applies to LaserFiche versions 4 and 5.

A number of .DLL files in the LaserFiche Client installation folder (usually \Program files\LaserFiche\LFW) that may not be needed for network communications may be removed. There are two .DLL's that may be removed depending on the operating system the LaserFiche Server is installed on.

The following table shows the .dll's necessary for communication with a particular Server. For example, if the LaserFiche Client will only communicate with a NetWare server, then the LFSOCK32.dll and LFWSOCK.dll files may be removed.

Novell Netware: Windows NT:
LFNCP32.dllLFSOCK32.dll
LFWNCP.dllLFWSOCK.dll

More Information

For information on where to locate the LF.ini files, please refer to the article listed below:

100162 Finding the LF.ini File